Benvingudes i benvinguts al portal Linkat

La Linkat és la distribució educativa de GNU/Linux que ha iniciat i ofereix el Departament d'Ensenyament a la comunitat educativa. Es tracta d'un projecte de programari lliure que permet als centres educatius, però també a tota la societat, tenir accés de forma legal, gratuïta i amb suport tècnic professional, a un conjunt molt ampli d'aplicacions: educatives, d'ofimàtica, d'Internet, multimèdia...

Servidor Linkat 14.04 com a PDC  Final

  • Hola,

    estic configurant un nou servidor amb el Linkat EDU 14.04 server.

    Al meu centre conviuen màquines amb Linkat i Windows. el servidor Linkat que teniem actualment (Linkat 4) ens funcionava com a PDC i hi podiem donar d'alta les màquines amb Windows.

    - Quines modificacions cal fer a smb.conf per què treballi també com a PDC? He fet algunes modificacions però no estic segur si el funcionament és correcte. https://goo.gl/XTZz6Y

    -Amb els canvis fets a smb.conf (per revisar), quan donem d'alta les màquines Windows ens demana un nom d'usuari i contrasenya però sempre em diu que és erroni.

    Ens podrieu dir què cal modificar per posar-ho en funcionament?

    Moltes gràcies.

    Salut!!!

    Joan
  • Hola Joan,


    És un dels temes que tinc pendent de documentar. Entre avui i demà publico a la wikilinkat la forma com transformar el servei Samba del serivdor 14.04 per tal que actuï com a PDC.


    Joan de Gracia
  • Hola Joan,


    Només una cosa, pots donar-me el resultat de l'ordre:

    net getlocalsid


    Gràcies,


    Joan
  • Hola Joan,

    aquest és el resultat:

    lnadmin@servidor:~$ net getlocalsid
    Failed to open /var/lib/samba/private/secrets.tdb
    Failed to open /var/lib/samba/private/secrets.tdb
    fetch_ldap_pw: neither ldap secret retrieved!
    pdb_init_ldapsam_common: Failed to retrieve LDAP password from secrets.tdb
    pdb backend ldapsam:"ldap://localhost/" did not correctly init (error was NT_STATUS_NO_MEMORY)
    WARNING: Could not open passdb
    lnadmin@servidor:~$

    Salut!!!

    Joan
  • Hola Joan,

    Bé l'ordre que t'havia passat s'havia d'executar com a usuari root. Sorry per no haver-t'ho comentat abans.

    De totes formes, em faria falta que fessis una extracció del contingut del servei ldap del servidor de centre. Això pots fer-ho com a usuari lnadmin si executes l'ordre:

    ldapsearch -x -D "cn=admin,dc=intracentre" -w CONTRASENYA > copia_ldap.ldif

    Dins del fitxer, mira a veure si tens unes unitats organitzatives anomenades:

    Domain Computers
    Domain Admins
    .....

    n'hi ha d'altres unitats organitzatives però si n'hi ha una d'aquestes, les altres també han de ser-hi.

    En cas que no hi siguin, digues-m'ho perquè et diré el procediment a seguir.

    :)



    Joan
  • Hola Joan,

    el resultat de la comanda executada com a root és:

    root@servidor:/home/lnadmin# net getlocalsid
    SID for domain SERVIDOR is: S-1-5-21-529981426-2723229455-1094128495
    root@servidor:/home/lnadmin#

    Salut!!!

    Joan
  • Hola,

    adjunto fitxer amb el contingut del servei ldap: https://goo.gl/MJaUn2.

    Salut!!!

    Joan
  • Gràcies per la informació Joan,


    Et passo la recepta el més aviat possible.


    :)


    Joan
  • Hola Joan,


    Gràcies per la informació que m'has proporcionat.

    Per transformat el servidor samba que porta la 14.04 en un PDC cal que facis el següent:


    1- Entra amb l'usuari lnadmin, obre un terminal i executa l'ordre:

    Code

    su


    per entrar com a root.

    2- Executa l'ordre:

    Code

    smbldap-populate


    i defineix la contrasenya de l'usuari root per al servei Samba.

    3- Edita el fitxer de configuració de samba:

    Code

    gedit /etc/samba/smb.conf


    Abans però, si vols pots fer una còpia de seguretat de la configuració. Només cal que escriguis les ordres:

    Code

    cp /etc/samba/smb.conf /etc/samba/smb.conf.$(date +%F)


    Recorda que el terminal l'has obert com a root per la qual cosa podràs editar el fitxer.

    4- Introdueix les modificacions següents:

    4.1 Afegir a la secció [global]:

    Code

    idmap_ldb:use rfc2307 = yes


    - Desmarcar i modificar:

    Code

    domain logons = yes
        domain master = yes
        os level = 64
        logon path =
        logon home =
        logon drive = H:
        logon script =


    4.2- Afegir secció [homes]:

    Code

    [homes]
       comment = Home Directories
       browseable = no
       read only = no
       create mask = 0700
       directory mask = 0700
       valid users = %S


    4.3- Modificar la secció [NETLOGON]:

    Code

    [NETLOGON]
       comment = Network Logon Service  
       path = /var/lib/samba/netlogon
       guest ok = yes
       browseable = no
       share modes = no


    Un cop introduïdes aquestes modificacions, reinicia el servidor Linkat 14.04. Si tot ha anat bé, podràs integrar novament les màquines Windows al domini Samba. Recorda que per al Windows XP és possible que hagis de canviar l'entrada al registre. Pots consultar la URL:

    http://ateneu.x…l_5/practica_2


    En el cas del Windows 7 és possible que també hagis de canviar alguna cosa al registre. Pots crear un fitxer .reg amb l'editor de text i incloure el contingut següent:

    Code

    Windows Registry Editor Version 5.00
     
    [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters]
    "DNSNameResolutionRequired"=dword:00000000
    "DomainCompatibilityMode"=dword:00000001

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Netlogon\Parameters]
    "RequireSignOrSeal"=dword:00000001
    "RequireStrongKey"=dword:00000001


    Bé, ja ens diràs com t'ha anat.

    :)


    Joan de Gracia



    Editat per jgraci25 el 30/Jul/2015 - 16:50.
  • Hola,

    de moment perfecte!!!

    he provat d'afegir una màquina amb xp i oli en un llum.
    Em falta provar w7 i iniciar sessió amb un usuari.

    Ja comentaré el resultat.

    Salut!!!

    Joan
  • Hola,

    modificant el registre les màquines amb w7 també es poden dona d'alta el domini.

    Problemes solucionats:
    - En iniciar sessió ni XP ni W/ carreguen el perfil
    Solució aplicada: he provat de deixar la configuració del servidor anterior de la secció profiles i ha funcionat. Els perfils de XP i de w7 queden desats en directoris ocults diferents (msprofile per XP i .msprofile.v2 per W7) . L'he deixat així:
    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
    browseable = no
    guest ok = no
    printable = no

    Problemes pendents de resoldre:
    - Iniciant sessió des de w7 no es connecta directament al home de l'usuari
    - Els scripts d'inici de sessió no s'executen ni amb XP ni amb W7 (fitxers cmd desats a path = /var/lib/samba/netlogon amb el nom del grup d'usuaris al que s'ha d'aplicar l'script)

    Bon estiu,

    Joan
  • Hola Joan,


    Bé, pel que entenc la integració s'ha fer correctament però fallen els scripts d'execució automàtics dels Windows i la connexió dels directoris "home" dels usuaris.

    M'ho miro i et dic alguna cosa.

    Merci pel feed-back Joan.

    :)


    Joan
  • 0 usuaris

Aquesta llista mostra els usuaris actius durant els darrers 20 minuts.