Benvingudes i benvinguts al portal Linkat

La Linkat és la distribució educativa de GNU/Linux que ha iniciat i ofereix el Departament d'Ensenyament a la comunitat educativa. Es tracta d'un projecte de programari lliure que permet als centres educatius, però també a tota la societat, tenir accés de forma legal, gratuïta i amb suport tècnic professional, a un conjunt molt ampli d'aplicacions: educatives, d'ofimàtica, d'Internet, multimèdia...

Errors després de fer una actualització en un servidor Linkat 3.0  Final

  • He actualitzat mitjanzant zypper up.
    Ho ha fet amb algunes inconsistències (no sé si s'havia fet mai). He passat diverses vegades el zypper fins que li ha faltat unes fonts uni.
    He hagut de reiniciar i a partir d'aquí no troba el driver de la targeta gràfica: mga_drv.so.

    Per altra banda no m'arrenca el yast ni en mode text.

    El servidor en qüestió és: Proliant ML150G6

    Em podrieu indicar què fer?
  • Hola,

    Segurament tenies problemes de dependències o conflictes de paquets. Per recuperar un sistema l'únic que es pot fer és un zypper dup, però no et garanteixo que et funcioni. Té molt mala pinta que no arranqui el YaST.

    A veure si et fucniona.

    Salut.

    Projecte Linkat
  • Per recuperar un sistema l'únic que es pot fer és un zypper dup, però no et garanteixo que et funcioni. Té molt mala pinta que no arranqui el YaST.
    Em reservo aquesta solució ... per després
    Em podries dir quins són els repositoris que cal que estiguin configurats? Per la Linkat 3.0 Servidor.

    El següent error és el que em dóna quan vull arrencar el yast en modus text:

    /usr/lib/YaST2/bin/y2base: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libblocxx.so.6)

    Si faig zypper ve:

    servidor:~ # zypper ve
    Loading repository data...
    Warning: Repository 'openSUSE-Update' appears to outdated. Consider using a different mirror or server.
    Reading installed packages...
    Some of the dependencies of installed packages are broken. In order to fix these dependencies, the following actions need to be taken:

    The following package is going to be REMOVED:
    seahorse


    After the operation, 2.4 M will be freed.
    Continue? [YES/no]:

    Encara que accepti no puc esborrar l'arxiu.

    En el servidor hi ha alguna còpia de seguretat...
  • Hola,

    Quan executes el YaST et demana les GLIB 3.4, la Linkat 3 porta GLIB 2.18. Aquí tens un greu problema.

    Sembla que has afegit uns repositoris d'altres versions d'opensuse o linkat i has fet una actualització de tot el sistema, el que ha produït aquesta inestabilitat, pot ser això el que ha passat?
    L'única solució és tornar a instal·lar la Linkat.

    Si el /home es troba en una partició separada, només et caldrà instal·lar la Linkat a la partició arrel i muntar la partició /home després sense formatar.

    Salut.

    Projecte Linkat
  • El servidor el fem servir com a servidor de fitxers (unitats... G T S P) potser el que m'interessa en comptes del /home és el /srv/exports.

    En el /home crec que no hi ha res d'interès.
  • Suposo que posats a fer és millor que instal·li el servidor en Linkat 4, oi?

    De fet tret dels errors que he comentat el servidor funciona bé i puc entrar per ssh o per consoles...
  • Hola,

    Fes una copia de les unitats compartides P, S i T i després fes la instal·la la Linkat 4 com a servidor. Així tindràs una instal·lació sense errors.

    Salut.

    Projecte Linkat
  • 0 usuaris

Aquesta llista mostra els usuaris actius durant els darrers 20 minuts.