Benvingudes i benvinguts al portal Linkat

La Linkat és la distribució educativa de GNU/Linux que ha iniciat i ofereix el Departament d'Ensenyament a la comunitat educativa. Es tracta d'un projecte de programari lliure que permet als centres educatius, però també a tota la societat, tenir accés de forma legal, gratuïta i amb suport tècnic professional, a un conjunt molt ampli d'aplicacions: educatives, d'ofimàtica, d'Internet, multimèdia...

Nova versió (31 juliol 2017) ActivInspire i ActivDriver funciona amb PDI Promethean i Linkat 16.04  Final

  • Promethean va treure una nova versió el 31 juliol 2017 que funciona amb Linkat 16.04 (64bit):
    https://support.prometheanworld.com/
    ActivInspire 2.10 released 31 July 2017. This version supports Ubuntu 16.04 (32-bit and 64-bit). Please visit the community to view the release notes.

    Ho he provat i funciona amb les PDI Promethean (lsusb 0d48:0004). Anteriorment havia provat la recepta provisional de http://linkat.xtec.cat/portal_linkat/wikilinkat/index.php/Promethean i no funciona (es queda penjat).

    Les instruccions originals són dobles:
    a) Programari interactiu
    1017 - Installing ActivInspire on Linux https://support.prometheanworld.com/article/?kb=1017
    b) Drivers pel reconeixement de maquinari
    1623 - How do I install ActivDriver on Linux Ubuntu 16.04? https://support.prometheanworld.com/article/?kb=1623

    La meva "recepta":
    a) Programari interactiu
    • Afegir un fitxer de dipòsit: $ sudo nano /etc/apt/sources.list.d/activsoftware.list
    afegir la següent línia: deb http://activsoftware.co.uk/linux/repos/ubuntu xenial non-oss
    i desar el fitxer.
    • Descarregar el fitxer amb la clau d'autenticació de dipòsit: $ wget http://activsoftware.co.uk/linux/repos/driver/PrometheanLtd.asc
    • Afegir la clau d'autenticació: $ sudo apt-key add PrometheanLtd.asc
    • Actualitzar la cache del dipòsit: $ sudo apt update
    • Instal·lar els paquets d'ActivInspire pels llenguatges desitjats: $ sudo apt install activ-meta-ca, (i/o activ-meta-en-gb, activ-meta-es, etc.)

    En executar ActiveInspire per primera vegada:
    Nom d’usuari: nom del centre
    Organització: Departament d’ Ensenyament
    Número de sèrie: treure'l d'un DVD d'instal·lació de Promethean

    b) Drivers pel reconeixement de maquinari
    • Editar el fitxer de dipòsit: $sudo nano /etc/apt/sources.list.d/activsoftware.list
    afegir la línia: deb http://activsoftware.co.uk/linux/repos/driver/ubuntu xenial oss non-oss
    i desar el fitxer.
    • Descarregar el fitxer amb la clau d'autenticació del dipòsit (si no ho heu fet abans): $ wget http://activsoftware.co.uk/linux/repos/driver/PrometheanLtd.asc
    • Afegir la clau d'autenticació (si no ho heu fet abans): $ sudo apt-key add PrometheanLtd.asc
    • Actualitzar la caché del dipòsit: $ sudo apt update
    • Instal·lar el paquet de l'ActivDriver: $ sudo apt install activtools
    • Reiniciar.

    c) Afegir el paquet de recursos per fer activitats interactives
    Descarrega ActivInspire Main Resource Pack
    http://activinspire.s3.amazonaws.com/resource_pack/ActivInspire_main_res_v1.1_ENU.as4a
    Importar el paquet de recursos en la biblioteca de recursos comuns (menú Fitxer dins ActiveInspire).

    Compte que el dipòsit de l'ActivInspire és diferent de l'ActivDriver. S'instal·len força dependències perquè el programari és de 32bit i calen llibreries pel sistema de 64bit.

    Aquest programari era un dels obstacles per canviar a la Linkat una escola sencera!.
    --
    Toni Ubieto
  • Moltes gràcies Antoni,


    Ho passarem a la wikilinkat.


    Molt bona feina.

    :)


    Joan de Gracia
  • Per a aquests casos, jo tinc programat un script que em fa la feina tota sola.
    Per a la SmartBoard i altres PDIs habituals els podeu trobar a https://github.…ive/master.zip

    Ja funcionava amb la 14.04 i vaig fer les modificacions pertinents perquè continues funcionant amb la 16.04.
    Ho he provat i funciona correctament, però està bé saber aquesta solució alternativa per si de cas algun dia falla.

    Gràcies



    Editat per joanborras el 21/Oct/2017 - 18:34.

    Joan Borràs Alsina
    Tècnic de Manteniment Preventiu al Vallès Occidental
  • He intentat instal·lar tal i com ha indicat l'Antoni, i només he pogut instal·lar el programari d'activinspire, no troba el paquet del drivers ni l'activtools. He intentat instal·lar aquest paquets baixant-me'ls des de wiki linkat i em dona errors a la instal·lació.

    Gràcies.

    Joan Martínez
  • Doncs a mi no hi ha manera que em funcioni. Després d'instal·lar els drivers i reiniciar apareix la icona de l'activmgr a la barra de dalt si el cable de la pissarra no està connectat. Quan connecto el cable, la icona desapareix i no detecta la pissarra. Ho he provat de totes maneres, amb la Linkat 64 bits, amb la 32 bits, amb ordinadors diferents, amb pissarres diferents, i no hi ha manera que les detecti. Els drivers per Linkat 16.04 que hi havia abans d'activar el repositori tampoc ens funcionaven.
    Encara anem amb la Linkat 14.04 i ens convindria fer una actualització.
    Alguna idea?

    Gràcies

    Narcís Masmartí
    Institut El Pedró
  • Espero ser d'ajuda, he recopilat el màxim d'informació amb l'ajuda de la Wiki de Linkat i de la gent de promethean i ho he ajuntat tot aquí:
    https://mainkiv…nux#Prometehan

    A mi em funciona perfectament inclús si actualitzo kernel.

    Tècnic informàtc Preventiu per al Departament d'Ensenyament
  • Bon dia,


    A veure, els drivers de la 16.04 haurien de funcionar correctament (tant la recepta anterior on hi havia un enllaç de descàrrega com l'actual via repositori). Segurament hi ha un problema amb les fonts del kernel. Pensa que Promethean ha de compilar un driver i segurament el problema està aquí, que el driver no es compila bé ja sigui perquè no hi ha les fonts del kernel o bé perquè falta algun compilador.

    D'altra banda indicar que, amb la 16.04 no tots els fabricants tenen els seus drivers actualitzats per a la 16.04. No obstant he estat fent proves amb diverses PDIs.

    Pissarres que funcionen directament amb la 16.04 són:


    - IQboard (usb-id - 1314:1103)
    - Smart 640/680 (usb-id - 0b8c:0001)

    Per calibrar cal instal·lar l'eina: xinput-calibrator


    - Promethean (usb-id - 0d48:0004) - Funciona amb la 16.04 amb els drivers de fabricant


    - Hitachi starboard (usb-id - 10c4:0655)

    El driver del fabricant no funciona bé amb la 16.04 i més si és de 64 bits. Per tal que funcioni cal seguir les indicacions que hi ha a:

    https://github.com/Makova/starboard-lsadrv

    - Interwrite:

    El driver funciona amb Java (openjdk) de 32 bits. He extret el driver d'aquesta pissarra i estic a l'espera de poder fer una prova de camp. En principi no hauria d'haver gaire problema ja que funciona amb openjdk de 32 bits.

    - Smart 480:

    Smart 480 funciona amb nwfermi i el el driver xf86-input-nextwindow no cal instal·lar-lo. Es pot instal·lar directament el driver del repositori següent: xserver-xorg-input-evdev

    El paquet nwfermi es pot descarregar des de:


    64 bits:

    http://wiki.lliurex.net/tiki-download_file.php?fileId=2276

    32 bits:

    http://wiki.lliurex.net/tiki-download_file.php?fileId=2295

    També estic a l'espera de fer la prova de camp.


    - ebeam (usb-id: 2650:1311)

    ebeam funciona directament amb MrPDI. Estic a l'espera de fer una prova de connexió directa amb la pissarra. El que sí que puc assegurar és que funciona amb MrPDI.


    Tota aquesta explicació fa referència als drivers i no pas als programes de PDI. Per substituir el programari dels fabricants recomanem OpenSankoré (si tens 32 bits) o bé Openboard (64 bits).


    Falta la pissarra Mimio que té programari de 32 bits per a la 16.04. Intentaré veure com es comporta amb 64 bits.


    Joan de Gracia
  • No saps quant necessitava aquesta informació amb les Smart! gracies!

    Tècnic informàtc Preventiu per al Departament d'Ensenyament
  • Hola,


    Kike, aniria molt bé tenir aquest feedback sobre les PDIs. Si fas proves amb aquestes pissarres, t'agrairia molt que ens reportessis més informació sobre si ha anat bé o no. Ja et dic, properament he de fer proves de camp (en un cole :-p ) amb aquestes pissarres.

    Ja diràs i moltes gràcies.

    Per cert, si el tema dels drivers funciona, la part del programari de PDI (Notebook, ActivInspire, etc) es pot fer funcionar amb una altra solució que tinc desenvolupada. Vaig desenvolupar una solució per al ksociograma i ktechlab per fer funcionar aquest programari amb un chroot d'Ubuntu 10.04.

    Ja ens diràs doncs i molt agraït.

    :)


    Joan
  • Demà mateix fico en pràctica aquesta sol.lució amb les Smart en un Linkat de 64b.

    Tècnic informàtc Preventiu per al Departament d'Ensenyament
  • Hola Kike,

    Tens informació sobre les Smart? Quin model has provat? El 480 resulta més interessant donat que fa servir el nwfermi.

    Ja ens diràs.


    Joan
  • Bon dia Joan,
    ara estic barallant-me amb un LinkatEdu 16.04 de 64b i he estic intentant calibrar la pissarra amb mrpdi-gui o mrpdi-cli --auto, previament he descarregat de lliurex el paquet nwfermi i instal.lat.
    en mrpdi-gui detecta la pissarra i activa el calibrador, però cau quan el llapis toca la pissarra amb la següent errada:

    * Starting MrPDI gui
    * Loading settings
    * State:128
    * State:0
    * State:128
    * Run
    * Turning on 50200
    La instrucció no és permesa

    Jo continuaré intentant trobar una alternativa, però agraïria ajuda.

    Tècnic informàtc Preventiu per al Departament d'Ensenyament
  • 0 usuaris

Aquesta llista mostra els usuaris actius durant els darrers 20 minuts.