Benvingudes i benvinguts al portal Linkat

La Linkat és la distribució educativa de GNU/Linux que ha iniciat i ofereix el Departament d'Ensenyament a la comunitat educativa. Es tracta d'un projecte de programari lliure que permet als centres educatius, però també a tota la societat, tenir accés de forma legal, gratuïta i amb suport tècnic professional, a un conjunt molt ampli d'aplicacions: educatives, d'ofimàtica, d'Internet, multimèdia...

Instalació del PHP  Final

  • Hola,

    He instalat l'apache, mysql, etc. però falla al instalar el php. Quan faig:

    sudo apt-get install php libapache2-mod-php php-mycript php-mysql

    i la resposta es que els paquets libapache2-mod-php php-mycript php-mysql no els te..

    He mirat a la carpeta on són els paquets i no existeixen aquest 3 paquets.

    L'apache em funciona pero no el php, i tampoc el phpmyadmin.

    Que puc fer?
    Gràcies
  • Hola,

    No cal especificar totes les dependències, el paquet phpmyadmin hauria d'arrastrar les dependències necessàries.

    Fes anar les següents ordres:

    Code

    sudo apt update
    sudo apt install phpmyadmin mysql-server


    Segurament has d'iniciar el servei mysql amb l'ordre següent:

    Code

    sudo service mysql start


    Connecta al phpmyadmin amb l'URL http://localhost/phpmyadmin

    A veure si et funciona

    Projecte Linkat
  • No em surt res de res. Tinc la versió 14.04 de ubuntu.

    Vull fer un upgrade a la versio 16.10 per veure si aquest es el problema i res de res. Faig:
    $sudo apt-get update per actualitzars els paquets i despres
    $sudo apt-get upgrade i no actualitza el ubuntu a una nova versió

    No tinc instalatt el php i no n'hi ha forma de fer-ho. Lo del phpmyadmin res de res.

    En fi vaig una mica contrariat i no ser que fer
    Gràcies
  • Hola,

    Em pots enganxar el missatge que surt després d'executar les ordres següents:

    Code

    sudo apt update
    sudo apt install phpmyadmin mysql-server


    Salut.

    Projecte Linkat
  • Hola,
    Ja tinc instal·lat l'Ubuntu 16.04. Al instal·lar el phpmyadmin em dona aquest error:

    S'està descartant el fitxer 50unattended-upgrades.ucf-old al directori "/etc/apt/apt.conf.d/

    El fitxer 50unattended-upgrades.ucf-old està en aquest directori però el que hem fa pensar el el PUNT entre upgrades i ucf

    No funciona el php, es a dir http://localhost/info.php no surt res, el fitxer info.php existeix a /var/www/html

    L'apache funciona correctament i he pogut entrar en el mysql amb root

    Gràcies
    Eduard Romo
  • Hola,

    L'APT (programa instal·lador) té una opció incorrecta que t'està bloquejant qualsevol instal·lació. Esborra el fitxer 50unattended-upgrades.ucf-old amb l'ordre següent:

    Code

    sudo rm /etc/apt/apt.conf.d/50unattended-upgrades.ucf-old


    Torna a intentar instal·lar un altre cop el phpmyadmin a veure si ara pot:

    Code

    sudo apt-get update
    sudo apt-get install phpmyadmin mysql-server


    Si no pot, enganxa el missatge que et surt.

    Salut.

    Projecte Linkat
  • Hola,

    El PHP em funciona, era una errada meva. Tinc instalat el php 5 i dos versions del PHP 7 (php7.0 i php 7.1) Crec que la que em va es la php 7.0 quan faig http://localhost/info.php em retorna tota la informació del PHP: PHP Version 7.0.17-2+deb.sury.org~xenial+1


    El que no va es el phpmyadmin. Quan fai http://localhost/phpmyadmin L'error es:

    Not Found

    The requested URL /phpmyadmin was not found on this server.
    Apache/2.4.18 (Ubuntu) Server at localhost Port 80[/b]


    El phpmyadmin està instalat, he fe-. $ ln -s /usr/share/phpmyadmin /var/www

    Segurament que serà no res

    Gràcies, si tens alguan pista em faries un favor
    Eduard
  • Hola Eduard,

    Tens el sistema molt modificat. Esborra l'enllaç simbòlic que has fet, no cal fer-ho perquè funcioni el phpmyadmin, l'apache fa servir vhosts per gestionar les diferents webs i la configuració del phpmyadmin s'afegeix automàticament a /etc/apache/conf-available i s'activa també automàticament a /etc/apache/conf-enable.

    Només instal·lant el paquet ja es configura tot, no cal fer res.

    Ja tens el servei mysql instal·lat i engegat?

    Code

    sudo service mysql start


    Com has fet la instal·lació del PHP?! Als repositoris de la Linkat edu 16.04 només hi ha la versió 7.0.

    Pensa que Ubuntu ho posa molt fàcil i no cal fer res si fas servir els paquets oficials.

    A veure si t'arrenca.

    Projecte Linkat
  • Hola,

    Ja està. Va perfecte. He desinstal·lat el phpmyadmin i l'he tornat a instal·lar i ja puc veure el phpmyadmin.

    L'errada del PHP que no em funcionava era que en el fitxer info.php tenia <% php i sobre l'espai en blanc, es a dir <%php jajajajajaja.

    He gaudit perquè feia molts anys que no tocava el Linux.

    Bones vacances. Me'n vaig mes tranquil.

    M'ha fet patí jejeje
    Eduard
  • 0 usuaris

Aquesta llista mostra els usuaris actius durant els darrers 20 minuts.